US Production Increased Latency
Incident Report for Kenna Security
Resolved
This incident has been resolved.
Posted Nov 25, 2019 - 13:55 CST
Monitoring
Performance should be back to normal, we're currently monitoring.
Posted Nov 25, 2019 - 11:16 CST
Investigating
We are currently investigating an increased load on US Production causing latency.

More updates will be provided as they become available.
Posted Nov 25, 2019 - 10:51 CST
This incident affected: US (Dashboards and Reports, Connector Runs, Kenna API, Explorer View, Data Updates, Data Exports, General Application Functionality).