US Performance issues under investigation. Slow performance and fix loading.
Incident Report for Kenna Security
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 12:08 CDT
Identified
Issue around fix display has been resolved but some minor performance issues are being investigated.
Posted Oct 22, 2019 - 16:50 CDT
Investigating
We are currently investigating these issues. Send email to support@kennasecurity.com with any problems you are experiencing.
Posted Oct 22, 2019 - 07:45 CDT
This incident affected: US (Explorer View, General Application Functionality).