US Platform Outage
Incident Report for Kenna Security
Resolved
The Kenna US Platform is now reachable and functioning as expected.
Posted Aug 08, 2019 - 00:22 CDT
Investigating
The Kenna US Platform is currently experiencing an outage for all users. Our Operations team is currently investigating.
Posted Aug 08, 2019 - 00:14 CDT